Troubleshooting VSS framework and VSS writer related issues - Detailed.

book

Article ID: 100049538

calendar_today

Updated On:

Description

Error Message

VSS framework issue.
VSS Snapshot failure.
VSS writer failure.
Snapshot provider error.

Cause

Various issue can cause VSS errors or failures. It is important to understand which VSS writer and which VSS operation is causing backup or snapshot failure. "VSS Diag Viewer" helps us in identifying this.

Resolution

VSS Diagnostics tool can be used to identify VSS writers and Framework related issues - Using VSS Diagnostics

Step 1: Download and Install Windows SDK on the machine reporting VSS errors.

Step 2: Run vssagent.exe to generate output file.

  • Open Command Prompt as Administrator.
  • Change directory to "C:\Program Files (x86)\Windows Kits\10\bin\10.0.19041.0\x64"
  • Run Command - "vssagent.exe -gather VSS_log.xml"

This will generate VSS_log.xml file in same path.

 

Step 3: Open the VSS_log.xml file using "VSS Diag Viewer"

 

 

Step 4: Review "Writer Status" and "Failure code".

Go to Gathered data --> VSS Writers --> Select the VSS writer causing backup failure and review FailureCode and FailureString

 

Step 5: Review "Applications" and "System" logs.

Go to Gathered data -->  Event Logs --> Application and System logs.

 

Step 6: Review "VSS Events Diagnostics"

Go to Gathered data -->  VSS Events Diagnostics. Review the events logged at the time of snapshot/backup failure. This section provides detailed writer specific information regarding the operation which is failing

Example - GETSTATE, PRESNAPSHOT, POSTSNAPSHOT, FREEZE, THAW, IOCTL_FLUSH, PREPAREBACKUP, etc.

 

Step 7: Getting error code details.

Look up error message text using - The Microsoft Error Lookup Tool
The Microsoft Error Lookup Tool displays the message text that is associated with a hexadecimal status code (or other code).

 

Once VSS error code and error message is identified please contact Microsoft support to resolve VSS error.

 

Please note that this article references sites not owned or maintained by Veritas and, as such, Veritas is not responsible for the content portrayed on such sites, including any revisions to or deletions of content or third-party software on which this article relies. User is responsible for conducting all necessary due diligence prior to following the instructions described in this article.

 

Issue/Introduction

Troubleshooting VSS framework and VSS writer related issues - Detailed.