Troubleshooting backup failure with the error "V-79-57344-33928 - Access is denied." or "0xe0008488 - Access is denied."

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Article ID: 100031310

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Description

Error Message

V-79-57344-33928 - Access is denied.
or

0xe0008488 - Access is denied.

UMI code :V-79-57344-33928

Cause

The directories for which the above error is occurring are called "Profile Compatibility Junctions". These junctions have access rights that do not allow Backup Exec to traverse into them. Therefore, Backup Exec just skips these junctions silently. The above error occurs because the directory recognition has not been executed and the silent skipping has not happened.

Back up job fails with "Access is denied" error when trying to back up offline files. Offline files are the files that are stored locally, but originate from an Archival storage on network. The attribute 'O' stands for Offline and it is non-removable. Offline files shown in figure below :-

Backup Exec when tries to back up Archived file it actually tries to fetch the file from Archival system and back up job fails with Access denied error as it may not have access to Archival storage. Instead, it should back up only the shortcut or place holder.

The above error can also occur if Server have a third party snapshot provider installed, Backup Exec is not able to Auto Select Microsoft VSS for backups.

Resolution

When backing up Users directory using VSS and with the option "Back up files and directories by following symbolic links" selected, the backup job fails with the access denied error, so uncheck this option. (Figure 1).  

Regarding Offline files, Backup Exec will skip the offline files automatically. Ensure if the following settings persists. (Figure 1)

Right click the backup job and click on Edit, click Edit to edit backup stage and click on "Files and Folders" and remove check mark from all the options below:
        a) Enable single instance back up of NTFS volumes
        b) Back up files and directories by following junction points and mount points
        c) Back up files and directories by following symbolic links 
        d) Back up data in Remote Storage

Run the job again to back up offline file. This time it will skip offline files and the job will complete successfully.

Figure 1



The directories under Users\All Users for which the error occurs are Application Data, Desktop, Documents, Favorites, Start Menu, and Templates.

This error can also appear if the Operating System of the server which is getting backed up is upgraded. E.g. Windows 2003 server to Windows 2008 server. After upgrade, The junction points for backward compatibility with previous Windows platforms cause this issue.

This upgrade may give error or exceptions like (example):

Error:

V-79-57344-33928 - Access is denied.
Directory C:\Users\Administrator\Local Settings\Application Data was not found, or could not be accessed.

Exception:

Unable to open the item C:\Users\Administrator\Local Settings\Microsoft\Windows\UsrClass.dat - skipped.

 

The default locations of user data has changed in Microsoft Windows Vista and Microsoft Windows Server 2008. To ensure backward compatibility with previous Windows platforms, these operating systems create special junctions. These junctions redirect access from one directory to another. For example, %SystemDrive%\Users\\Local Settings is now a junction that points to %SystemDrive%\Users\\AppData\Local.

 For more information about which directories have changed in Windows Vista and Windows Server "Longhorn" see https://msdn2.microsoft.com/en-us/library/aa480152.aspx#appcomp_topic31

 

To resolve such issues occur after upgrading the Operating System, exclude the files and folders from the backup selection list or uncheck "Back up files and directories by following junction points" (Figure 1) in the backup job property.


Workaround

It is acceptable for Backup Exec to skip these directories as the user data can be backed up through the alternate paths. Therefore, this error can be ignored safely, as no data is lost.

Issues where getting the error "0xe0008488 - Access is denied." only on Differential backup and not on Full backup, check if Job is target to 'All device' in the job properties, if so, change it to specific device.

If third party snapshot provider is installed, first confirm by running the command "vssadmin list providers" on the target server. If yes, then as a workaround select the Microsoft VSS Provider manually:

Edit Backup job > Advance Open File > and manually select "System - Use Microsoft Software Shadow Copy Provider" > Run the backup job.

 

Issue/Introduction

Attempt to backup the Users directory using Microsoft Volume Shadow Copy Service (VSS) and following symbolic links fails with the error "V-79-57344-33928 - Access is denied." or when trying to backup offline files.

Additional Information

ETrack: 973497 UMI: V-79-57344-33928