The "Microsoft SQL Server" icon does not appear in the backup selections in Backup Exec for Windows Servers.

book

Article ID: 100029753

calendar_today

Updated On:

Description

Error Message

None

 

Cause

This normally happens when the backup account being used does not have sufficient permissions.

 

Resolution

Follow the procedure mentioned below to make sure that the backup account has sufficient permissions:

1. Confirm  that the 'Agent for Applications and Databases' feature has been installed\enabled in the Backup Exec Console. 

2. Confirm that the BEDSSQL2.dll file is present in the following directories on the SQL server:
<Install Dir>\Program Files\Veritas\Backup Exec\RAWS
 
3. Grant the 'System Administrator' role to the backup account, within the SQL application.

 
4. Confirm that a UDL test to the SQL instance is successful, from the SQL server locally. Follow this article to run a UDL test.  Note that the article is related to connecting to Backup Exec's own SQL instance but can be used for any SQL instance.
 

5. Grant 'Full Control' permissions to the backup account, on the following registry keys of the SQL SERVER:
 
  • HKEY_LOCAL_MACHINE\Software\Microsoft\Microsoft SQL Server
  • HKEY_LOCAL_MACHINE\Software\Microsoft\MSSQLServer
6. Restart the Remote Agent service on the SQL server. Browse to the remote SQL server and the "Microsoft SQL Server" icon should be listed in the backup selection list.

 

Issue/Introduction

The "Microsoft SQL Server" icon does not appear in the backup selections in Backup Exec for Windows Servers.

Error Message

None

Cause

This normally happens when the backup account being used does not have sufficient permissions.