Remote Agent for Linux and Unix Servers (RALUS) RMAN Backup fails with access denied when backing up Oracle from a Linux Machine when the agent and backup job are configured incorrectly.
"id oracle" . To change group membership, the "usermod" command is one option available /opt/VRTSralus/bin/AgentConfig Configure database access Add system credentials for Oracle operations Enter a user name that has local system credentials or the account you have created which is a member of beoper and oinstall groups Do you want to use the full computer name /IP address for Oracle operations? Enter the full computer name or IP address . Make a note of this value because it is required later and is case-sensitive. Do you want to use a custom port to connect to the media server during Oracle operations? Commit Oracle operation settings to the configuration file? Configure Oracle instance information Add a new Oracle instance to protect Enter the Oracle database SYSDBA user name . You can enter a different database user. Details for creating a different account are in the related article Enter the Oracle SYSDBA password Enter the media server name or IP address Do you use a recovery catalog Do you want to use a customized job template Commit Oracle operation settings to the configuration file? Database Access , step number 8. When using the FQDN, use the same capitalisation that was used when the value was entered in AgentConfig: the entry in AgentConfig needs to be consistent with the entry on the media server.
Remote Agent for Linux and Unix Servers (RALUS) RMAN Backup fails with access denied when backing up Oracle from a Linux Machine when the agent and backup job are configured incorrectly.